Category Archives: ccna basic

this categories in include ccna basic article

how to configure loopback interface in Cisco Router

Step 1 – at fast we will take two router and two pc and configure ip address like below image 

Step 2 IP address configuration on router 0 
Router>enable
Router#config terminal
Router(config)#hostname r1
r1(config)#interface FastEthernet0/0
r1(config-if)#ip address 1.0.0.1 255.0.0.0
r1(config-if)#no shutdown
r1(config-if)#exit
r1(config)#interface Serial0/0/0
r1(config-if)#ip address 2.0.0.1 255.0.0.0
r1(config-if)#no shutdown
r1(config-if)#exit
r1(config)#int loop 3
r1(config-if)#ip address 4.0.0.1 255.0.0.0
r1(config-if)#exit
r1(config)#int loop 4
r1(config-if)#ip address 5.0.0.1 255.0.0.0

Step 3  IP address Configuration for Router 1

Router>enable
Router#config terminal
Router(config)#hostname r2
r2(config)#interface FastEthernet0/0
r2(config-if)#ip address 3.0.0.1 255.0.0.0
r2(config-if)#no shutdown
r2(config-if)#exit
r2(config)#interface Serial0/0/0
r2(config-if)#ip address 2.0.0.2 255.0.0.0
r2(config-if)#no shutdown
r2(config-if)#exit
r2(config)#int loop 1
r2(config-if)#ip address 6.0.0.1 255.0.0.0
r2(config-if)#exit
r2(config)#int loop 2
r2(config-if)#ip address 7.0.0.1 255.0.0.0
r2(config-if)#exit

Step 4 Static routing for router 0

r1(config)#ip route 3.0.0.1 255.0.0.0 2.0.0.2
r1(config)#ip route 6.0.0.0 255.0.0.0 2.0.0.2
r1(config)#ip route 7.0.0.0 255.0.0.0 2.0.0.2

Step 5 Static routing for router 1

r1(config)#ip route 1.0.0.0 255.0.0.0 2.0.0.1
r1(config)#ip route 4.0.0.0 255.0.0.0 2.0.0.1
r1(config)#ip route 5.0.0.0 255.0.0.0 2.0.0.1

Now your work is Complete you can ping to each ip address. if you have any problem in this process please comments here i will solve your problem. If you want You can also download loop back ip lab through this likn   

Thank you

by Vishnu Sharma

Advertisements

About ip address , subnetmask and its binary conversion

hii guy today i am Telling about ip address. address are manually two types physical and logical IP address

logical address —  IPV4 (32 bit) IPV6(126 bit) we can look our pc or laptop ip open your cmd prompt and type { ipconfig } -Logical address are dynamic we can ask temporary because logical address always change when devices connect to the network. Network devices automatically provide logical ip  address

ip addres

Physical ip address– physical address is static address it deos,not change it is permanently address we can also call make address its size(48 bit ) we can look in to devices open your pc or laptop cmd promt and type { getmac }

we can understand about ip deeply through this example

IP version  4 is totally size 32bit IP version 4 divided in 5  classes class have  specified Sub net Mask we can understand like this

1 class A   (0-126)    exp. 10.22.23.7   submit mask (255.0.0.0)

2 class B   (127-191) exp. 132.15.29.7  submit mask (255.255.0.0)

3 class C (192-223) exp.193.123,142,10  submit mask  (255.255.255.0)

4 class D (224-239) this ip is used in gaming and multi-casting area

5 class E (240- 255)  this ip is reserve in research area

here we understand some simple example that how to identify  IP address  SubnetMask and binary conversion this example , I will use class C IP address and its submit mask

IP Address: 192 . 100 . 10 . 33

network bit host bit
255.255.255 0

its submitmask is  255.255.255.0 and binary conversen 11000000.01100100.00001010.00100001

128 64 32 16 8 4 2 1 ip address
1 1 0 0 0 0 0 0 192
0 1 1 0 0 1 0 0 100
0 0 0 0 1 0 1 0 10
0 0 1 0 0 0 0 1 33