Category Archives: ccna

in this categories article about CCNA and networking

how to configure loopback interface in Cisco Router

Step 1 – at fast we will take two router and two pc and configure ip address like below image 

Step 2 IP address configuration on router 0 
Router>enable
Router#config terminal
Router(config)#hostname r1
r1(config)#interface FastEthernet0/0
r1(config-if)#ip address 1.0.0.1 255.0.0.0
r1(config-if)#no shutdown
r1(config-if)#exit
r1(config)#interface Serial0/0/0
r1(config-if)#ip address 2.0.0.1 255.0.0.0
r1(config-if)#no shutdown
r1(config-if)#exit
r1(config)#int loop 3
r1(config-if)#ip address 4.0.0.1 255.0.0.0
r1(config-if)#exit
r1(config)#int loop 4
r1(config-if)#ip address 5.0.0.1 255.0.0.0

Step 3  IP address Configuration for Router 1

Router>enable
Router#config terminal
Router(config)#hostname r2
r2(config)#interface FastEthernet0/0
r2(config-if)#ip address 3.0.0.1 255.0.0.0
r2(config-if)#no shutdown
r2(config-if)#exit
r2(config)#interface Serial0/0/0
r2(config-if)#ip address 2.0.0.2 255.0.0.0
r2(config-if)#no shutdown
r2(config-if)#exit
r2(config)#int loop 1
r2(config-if)#ip address 6.0.0.1 255.0.0.0
r2(config-if)#exit
r2(config)#int loop 2
r2(config-if)#ip address 7.0.0.1 255.0.0.0
r2(config-if)#exit

Step 4 Static routing for router 0

r1(config)#ip route 3.0.0.1 255.0.0.0 2.0.0.2
r1(config)#ip route 6.0.0.0 255.0.0.0 2.0.0.2
r1(config)#ip route 7.0.0.0 255.0.0.0 2.0.0.2

Step 5 Static routing for router 1

r1(config)#ip route 1.0.0.0 255.0.0.0 2.0.0.1
r1(config)#ip route 4.0.0.0 255.0.0.0 2.0.0.1
r1(config)#ip route 5.0.0.0 255.0.0.0 2.0.0.1

Now your work is Complete you can ping to each ip address. if you have any problem in this process please comments here i will solve your problem. If you want You can also download loop back ip lab through this likn   

Thank you

by Vishnu Sharma

Advertisements

How to configure VLAN in Cisco Switch

Hello guys today we will learn how to configure VLAN(Virtual Area network) in Cisco Switch. Before that we will learn what is VLAN. we can create block in same network through vlan. some times we have to need network block in same network,  imagine that we want to create two networks block in computer lab and our condition  is both block cant’communicate each-other in this condition we will configure VLAN in Switch  you just follow simple Steps

before we will take two switch and eight Computer and provide ip address like this tables

PC 0 PC 1 PC 2 PC 3 PC 4 PC 5 PC 6 PC 7
1.0.0.1 1.0.0.2 1.0.0.3 1.0.0.4 1.0.0.5 1.0.0.6 1.0.0.7 1.0.0.8

Step 2 now will go to switch 1 CLI mod and configure vlan like this

vlan

Switch>en

Switch#config t
Enter configuration commands, one per line. End with CNTL/Z.
Switch(config)#vlan 10
Switch(config-vlan)#name ccna
Switch(config-vlan)#exit
Switch(config)#int Fa0/1
Switch(config-if)#switchport mode access
Switch(config-if)#switchport access vlan 10
Switch(config-if)#exit
Switch(config)#int fa0/2
Switch(config-if)#switchport mode access
Switch(config-if)#switchport access vlan 10
Switch(config-if)#exit
Switch(config)#vlan 20
Switch(config-vlan)#name linux
Switch(config-vlan)#exit
Switch(config)#int fa0/3
Switch(config-if)#switchport mode access
Switch(config-if)#switchport access vlan 20
Switch(config-if)#exit
Switch(config)#int Fa0/4
Switch(config-if)#switchport mode access
Switch(config-if)#switchport access vlan 20
Switch(config-if)#exit
Switch(config)#

Step 2 we can look our vlan through show vlan commands 

screenshot-83

Step 3 now will go to switchb 2  and Configuration vlan same like this

Switch#config t
Enter configuration commands, one per line. End with CNTL/Z.
Switch(config)#vlan 10
Switch(config-vlan)#name ccna
Switch(config-vlan)#exit
Switch(config)#int fa0/1
Switch(config-if)#switchport mod access
Switch(config-if)#switchport access vlan 10
Switch(config-if)#exit
Switch(config)#int fa0/2
Switch(config-if)#switchport mod access
Switch(config-if)#switchport access vlan 10
Switch(config-if)#exit
Switch(config)#vlan 20
Switch(config-vlan)#name linux
Switch(config-vlan)#int fa0/3
Switch(config-if)#switchport mod access
Switch(config-if)#switchport access vlan 20
Switch(config-if)#exit
Switch(config)#int fa0/4
Switch(config-if)#switchport mod access
Switch(config-if)#switchport access vlan 20
Switch(config-if)#exitvlan

Step 3 now we r connect both switch and connect VALN 10 and VLAN 20

vlan

Go to Switch 1 and configure trunk on port fa0/5
Switch>en
Switch#config t
Enter configuration commands, one per line. End with CNTL/Z.
Switch(config)#int fa0/5
Switch(config-if)#switchport trunk allowed vlan all
Switch(config-if)#switchport mode trunk
Switch(config-if)#

Now go to switch 2 and configure trunk on port fa0/5

Switch>en
Switch#config t
Enter configuration commands, one per line. End with CNTL/Z.
Switch(config)#int fa0/5
Switch(config-if)#switchport trunk allowed vlan all
Switch(config-if)#switchport mode trunk

now Cisco switch on complete VLAN configuretion

how to remove VLAN

if we want to remove VLAN then go to switch CLI mode and type just no vlan

Switch(config-if)#no vlan 10
Switch(config)#no vlan 20

if you have any problem in this process then comments here i will solve your problem you can also download vlan lab through this link 

Thank you

by Vishnu Sharma

How to configure RIP Routing in Cisco Packet tracer

hello guys today we will learn how to configure RiP(Routing Information protocol ) Routing in cisco packet tracer its a very simple process you just fillow my step

Rip routing

Step1.  before we will take three router and three pc and we assign ip address According chart   

PC0 1.0.0.2 default geteway 1.0.0.1
PC1 3.0.0.2 default geteway 3.0.0.1
PC2 5.0.0.2 default geteway 5.0.0.1
/Router/all Router port Se/0/0/0 Se/0/1/1 Fa0/0
ROUTER0 2.0.0.1 —– 1.0.0.1
ROUTER1 2.0.0.2 4.0.0.1 3.0.0.1
ROUTER2 ——- 4.0.0.2 5.0.0.1

Step2 we will go in Router 0 CLI mod and congigure ip address like this

Router>en
Router#config t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#int Fa0/0
Router(config-if)#ip address 1.0.0.1 255.0.0.0
Router(config-if)#no shut                                                                                                     Router(config-if)#exit
Router(config)#int Se0/0/0
Router(config-if)#ip address 2.0.0.1 255.0.0.0
Router(config-if)#no shut

Step2  now we will go Router1 CLI mod and configure io address

Router>en
Router#config t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#int Fa0/0
Router(config-if)#ip address 3.0.0.1 255.0.0.0
Router(config-if)#no shut
Router(config)#exit
Router(config)#int Se0/0/0
Router(config-if)#ip address 2.0.0.2 255.0.0.0
Router(config-if)#no shut
Router(config)#exit
Router(config)#int Se0/1/1
Router(config-if)#ip address 4.0.0.1 255.0.0.0
Router(config-if)#no shut

Srep3 and now we will configure ip address in router2

Router>en
Router#config t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#int Fa0/0
Router(config-if)#ip address 5.0.0.1 255.0.0.0
Router(config-if)#no shut
Router(config-if)#exit
Router(config)#int Se0/1/1
Router(config-if)#ip address 4.0.0.2 255.0.0.0
Router(config-if)#no shut

Step 4 After ip address configuration we will configure each router in ip RIP routing like this

Router o

Router(config)#router rip
Router(config-router)#network 1.0.0.0
Router(config-router)#network 2.0.0.0

Router 1

Router(config)#router rip
Router(config-router)#network 2.0.0.0
Router(config-router)#network 3.0.0.0
Router(config-router)#network 4.0.0.0

Router 2

Router(config)#router rip
Router(config-router)#network 5.0.0.0
Router(config-router)#network 4.0.0.0

if you have problem in this rip routing so comment here i will solve your problem. you can also download rip routing lab through this link

thank you

by Vishnu  Sharma

How to Single Router working as Multiple DHCP Server Packet Tracer Lab

hello guys today we will discuss about DHCP router how can we provide ip address in different  network through router.actually we will make DHCP router and configure ip address through router.if you are interested in networking field or u prepare any networking exam so this tutorial is a very help full for  you. so let we startdhcp router

Step1 we will take three router and eight pc and create like this structure

Step 2 we will make router0 dhcp server. before we create connection each-other pc and router 

Step3 we will take serial wire and connect all router each-other 

Step 4 codeing for all routers 

ROUTER 0

Router>enable
Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#interface FastEthernet0/0
Router(config-if)#ip address 1.0.0.1 255.0.0.0
Router(config-if)#no shutdown
Router(config-if)#exit
Router(config)#interface Serial0/1/0
Router(config-if)#ip address 2.0.0.1 255.0.0.0
Router(config-if)#no shutdown

 

ROUTER 1

Router>enable
Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#interface FastEthernet0/0
Router(config-if)#ip address 3.0.0.1 255.0.0.0
Router(config-if)#no shutdown
Router(config-if)#exit
Router(config)#interface Serial0/0/0
Router(config-if)#ip address 2.0.0.2 255.0.0.0
Router(config-if)#no shutdown
Router(config-if)#exit
Router(config)#interface Serial0/0/1
ip address 4.0.0.1 255.0.0.0
Router(config-if)#no shutdown

 

ROUTER 2

Router>enable
Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#interface Serial0/0/0
Router(config-if)#ip address 4.0.0.2 255.0.0.0
Router(config-if)#no shutdown
Router(config-if)#exit
Router(config)#interface FastEthernet0/0
Router(config-if)#ip address 5.0.0.1 255.0.0.0
Router(config-if)#no shutdown
Router(config-if)#exit
Router(config)#interface FastEthernet0/1
Router(config-if)#ip address 6.0.0.1 255.0.0.0
Router(config-if)#no shutdown

 

Step 4 then we configure static routing for all router

STATIC ROUTING FOR ROUTER 0

Router(config)#ip route 4.0.0.0 255.0.0.0 2.0.0.2
Router(config)#ip route 5.0.0.0 255.0.0.0 2.0.0.2
Router(config)#ip route 6.0.0.0 255.0.0.0 2.0.0.2
Router(config)#ip route 3.0.0.0 255.0.0.0 2.0.0.2

STATIC ROUTING FOR ROUTER 1

Router(config)#ip route 1.0.0.0 255.0.0.0 2.0.0.1
Router(config)#ip route 5.0.0.0 255.0.0.0 4.0.0.2
Router(config)#ip route 6.0.0.0 255.0.0.0 4.0.0.2

STATIC ROUTING FOR ROUTER 2

Router(config)#ip route 2.0.0.0 255.0.0.0 4.0.0.1
Router(config)#ip route 3.0.0.0 255.0.0.0 4.0.0.1
Router(config)#ip route 1.0.0.0 255.0.0.0 4.0.0.1

Step 5 After static routing configuration we will go on router 0 and configure networl pool for all router 

Network pool one  for pc0 and pc1

Router(config-if)#ip dhcp pool one
Router(dhcp-config)#network 1.0.0.0 255.0.0.0
Router(dhcp-config)#default-router 1.0.0.1 

Network pool two   for pc 2 pc 3

Router(config)#interface Serial0/1/0
Router(config-if)#ip dhcp pool two
Router(dhcp-config)#network 3.0.0.0 255.0.0.0
Router(dhcp-config)#default-router 3.0.0.1

Network pool routerthree for pc 4  pc 5

Router(config-if)#ip dhcp pool routerthree
Router(dhcp-config)#network 5.0.0.0 255.0.0.0
Router(dhcp-config)#default-router 5.0.0.1

Network pool routerfour  for pc6 pc7

Router(config-if)#ip dhcp pool routerfour
Router(dhcp-config)#network 6.0.0.0 255.0.0.0
Router(dhcp-config)#default-router 6.0.0.1

Step6 now we wiil go in router1 and open FastEthernet0/0 port and put below commands

Router(config-if)#ip helper-address 2.0.0.1

now open pc2 and pc 3  ip configuration window and click on DHCP then you will get ip address dhcp routersame like we will go on router 2 command prompt and type below commands

network port  FastEthernet0/0         Router(config-if)#ip helper-address 2.0.0.1

network port  FastEthernet0/1         Router(config-if)#ip helper-address 2.0.0.1

if you have any problem in this process please comment here i will solve your problems.  you can also download  Single Router working as Multiple DHCP Server:Packet Tracer Lab through this link just one click and download

 

Thank you

by Vishnu Sharma

How to configure static routing with 5 Router in Cisco Packet tracer

hello guys today we will learn how to configure static routing with 5 router .Its a very simple method before we take 5 router and four  4 Pc then we will connected with Serial wire like this Screen short

Static routing

 We will provide ip address every pc 

pc 0= ip address is 4.0.0.2 and default getaway 4.0.0.1

pc 1= ip address is 1.0.0.2 and default getaway 1.0.0.1

pc 2= ip address is 2.0.0.2 and default getaway 2.0.0.1

pc 0= ip address is 3.0.0.2 and default getaway 3.0.0.1

Continue reading

How to configure Static Routing with 4 router in Cisco Packet Tracer

Hello guys today we will learn how can we configure static routing in Cisco Packet Tracer .so here i take four router and four PC and connect each-other.so according to condition  i have eight (8) network so i just configure static routeing in this .

ststic routing

here we will also provide ip address for pc  provide

pc0 = ip address is  5.0.0. default ip 5.0.0.1

pc1=ip address 6.0.0.2 default  ip 6.0.0.1

pc2= ip address 7.0.0.2 default ip 7.0.0.1

pc3= ip address 8.0.0.2 default ip 8.0.0.2

Step 1 Here now i am going to router in  0 and provide ip address

Router>enable
 Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#interface FastEthernet0/0
 Router(config-if)#ip address 8.0.0.1 255.0.0.0
 Router(config-if)#no shutdown
Router(config-if)#
 %LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up
 %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up
Router(config-if)#exit
 Router(config)#interface Serial0/0/0
 Router(config-if)#ip address 3.0.0.2 255.0.0.0
 Router(config-if)#no shutdown
%LINK-5-CHANGED: Interface Serial0/0/0, changed state to up
Router(config-if)#exit
 Router(config)#interface Serial0/0/1
Router(config-if)#
 %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0/0, changed state to up
 ip address 4.0.0.1 255.0.0.0
Router(config-if)#no shutdown

Step 1 Here now i am going to router in  1 and provide ip address

Router>enable
Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#interface Serial0/0/1
Router(config-if)#ip address 1.0.0.1 255.0.0.0
Router(config-if)#no shutdown
%LINK-5-CHANGED: Interface Serial0/0/1, changed state to down
Router(config-if)#
 Router(config-if)#exit
 Router(config)#interface Serial0/0/0
 Router(config-if)#ip address 4.0.0.2 255.0.0.0
 Router(config-if)#no shutdown
%LINK-5-CHANGED: Interface Serial0/0/0, changed state to down
Router(config-if)#
 Router(config-if)#exit
 Router(config)#interface FastEthernet0/0
 Router(config-if)#ip address 5.0.0.1 255.0.0.0
 Router(config-if)#no shutdown

 
Step 1 Here now i am going to router in  2and provide ip address

 Router>enable
 Router#configure terminal
Router(config)#interface FastEthernet0/0
 Router(config-if)#ip address 7.0.0.1 255.0.0.0
 Router(config-if)#no shutdown
Router(config-if)#
%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up
Router(config-if)#exit
 Router(config)#interface Serial0/0/1
 Router(config-if)#ip address 2.0.0.2 255.0.0.0
 Router(config-if)#no shutdown
Router(config-if)#
%LINK-5-CHANGED: Interface Serial0/0/1, changed state to up
Router(config-if)#exit
 Router(config)#interface Serial0/0/0
Router(config-if)#
%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0/1, changed state to up
ip address 3.0.0.1 255.0.0.0
Router(config-if)#no shutdown

Step 3 Here now i am going to router in  3 and provide ip address

Router>enable
Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#interface FastEthernet0/0
Router(config-if)#ip address 6.0.0.1 255.0.0.0
Router(config-if)#no shutdown
Router(config-if)#
%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up
Router(config-if)#exit
Router(config)#interface Serial0/0/0
Router(config-if)#ip address 1.0.0.2 255.0.0.0
Router(config-if)#no shutdown
Router(config-if)#
%LINK-5-CHANGED: Interface Serial0/0/0, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0/0, changed state to up
Router(config-if)#exit
Router(config)#interface Serial0/0/1
Router(config-if)#ip address 2.0.0.1 255.0.0.0
Router(config-if)#no shutdown

 

Step 4 After ip address provide we configure static routing in router 0

Router(config)#ip route 5.0.0.0 255.0.0.0 4.0.0.2
Router(config)#ip route 1.0.0.0 255.0.0.0 4.0.0.2
Router(config)#ip route 6.0.0.0 255.0.0.0 4.0.0.2
Router(config)#ip route 2.0.0.0 255.0.0.0 4.0.0.2
Router(config)#ip route 7.0.0.0 255.0.0.0 3.0.0.1
Router(config)#ip route 2.0.0.0 255.0.0.0 3.0.0.1
Router(config)#ip route 6.0.0.0 255.0.0.0 3.0.0.1
Router(config)#ip route 1.0.0.0 255.0.0.0 3.0.0.1

Routing for Router 1

Router(config)#ip route 5.0.0.0 255.0.0.0 4.0.0.2
Router(config)#ip route 1.0.0.0 255.0.0.0 4.0.0.2
Router(config)#ip route 6.0.0.0 255.0.0.0 4.0.0.2
Router(config)#ip route 2.0.0.0 255.0.0.0 4.0.0.2
Router(config)#ip route 7.0.0.0 255.0.0.0 3.0.0.1
Router(config)#ip route 2.0.0.0 255.0.0.0 3.0.0.1
Router(config)#ip route 6.0.0.0 255.0.0.0 3.0.0.1
Router(config)#ip route 1.0.0.0 255.0.0.0 3.0.0.1

Routing for Router 2

Router(config)#ip route 8.0.0.0 255.0.0.0 3.0.0.2
Router(config)#ip route 4.0.0.0 255.0.0.0 3.0.0.2
Router(config)#ip route 5.0.0.0 255.0.0.0 3.0.0.2
Router(config)#ip route 1.0.0.0 255.0.0.0 3.0.0.2
Router(config)#ip route 6.0.0.0 255.0.0.0 2.0.0.1
Router(config)#ip route 1.0.0.0 255.0.0.0 2.0.0.1
Router(config)#ip route 5.0.0.0 255.0.0.0 2.0.0.1

Routing for Router 3

Router(config)#ip route 5.0.0.0 255.0.0.0 1.0.0.1
Router(config)#ip route 4.0.0.0 255.0.0.0 1.0.0.1
Router(config)#ip route 8.0.0.0 255.0.0.0 1.0.0.1
Router(config)#ip route 3.0.0.0 255.0.0.0 1.0.0.1
Router(config)#ip route 7.0.0.0 255.0.0.0 2.0.0.2
Router(config)#ip route 3.0.0.0 255.0.0.0 2.0.0.2
Router(config)#ip route 8.0.0.0 255.0.0.0 2.0.0.2

IF you will have any problem in this routing you can download static routing lab click to this link download  ,

thank you

by vishnu sharma

 

How to configure static routing in Cisco packet tracer

hello guys today we will learn how to configure static routing  in Cisco packet tracer

ststic routing

step 1 go to router 0 CLI mode and jus type 

Router>en

Router#config t

Router(config)#int Fa0/1

Router(config-if)#ip address 1.0.0.1 255.0.0.0

Router(config-if)#no shut

Router(config)#int fa0/0                                                                                                                             Router(config-if)#ip address 2.0.0.1 255.0.0.0

Router(config-if)#no shut

step 2 Here we configure our pc 0 ip address  1.0.0.2 and default gateway 1.0.0.1

ststic routing

Step 2 then we will go to Router 1 and configure its ip address

Router>en

Router#config t

Enter configuration commands, one per line. End with CNTL/Z.

Router(config)#int Fa0/1

Router(config-if)#ip address 3.0.0.1 255.0.0.0

Router(config-if)#no shut

Router(config-if)#exit

Router(config)#int Fa0/0

Router(config-if)#ip address 2.0.0.2 255.0.0.0

Router(config-if)#no shut

Step 3 then go pc 1 and here also configure ip address 3.0.0.2 and default Gateay 3.0.0.1

ststic routing

Step 4 then we will go to router 0 again and configure static routing 

Router(config-if)#exit

Router(config)#ip route 3.0.0.0 255.0.0.0 2.0.0.2

Step 5 then we will go to Router 1 and configure static routing 

Router(config)#ip route 1.0.0.0 255.0.0.0 2.0.0.1

Router(config)#exit

if you want to Cisco router labso Please click my link and download

Thank you

by vishnu sharma