Monthly Archives: January 2017

How to configure RIP Routing in Cisco Packet tracer

hello guys today we will learn how to configure RiP(Routing Information protocol ) Routing in cisco packet tracer its a very simple process you just fillow my step

Rip routing

Step1.  before we will take three router and three pc and we assign ip address According chart   

PC0 1.0.0.2 default geteway 1.0.0.1
PC1 3.0.0.2 default geteway 3.0.0.1
PC2 5.0.0.2 default geteway 5.0.0.1
/Router/all Router port Se/0/0/0 Se/0/1/1 Fa0/0
ROUTER0 2.0.0.1 —– 1.0.0.1
ROUTER1 2.0.0.2 4.0.0.1 3.0.0.1
ROUTER2 ——- 4.0.0.2 5.0.0.1

Step2 we will go in Router 0 CLI mod and congigure ip address like this

Router>en
Router#config t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#int Fa0/0
Router(config-if)#ip address 1.0.0.1 255.0.0.0
Router(config-if)#no shut                                                                                                     Router(config-if)#exit
Router(config)#int Se0/0/0
Router(config-if)#ip address 2.0.0.1 255.0.0.0
Router(config-if)#no shut

Step2  now we will go Router1 CLI mod and configure io address

Router>en
Router#config t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#int Fa0/0
Router(config-if)#ip address 3.0.0.1 255.0.0.0
Router(config-if)#no shut
Router(config)#exit
Router(config)#int Se0/0/0
Router(config-if)#ip address 2.0.0.2 255.0.0.0
Router(config-if)#no shut
Router(config)#exit
Router(config)#int Se0/1/1
Router(config-if)#ip address 4.0.0.1 255.0.0.0
Router(config-if)#no shut

Srep3 and now we will configure ip address in router2

Router>en
Router#config t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#int Fa0/0
Router(config-if)#ip address 5.0.0.1 255.0.0.0
Router(config-if)#no shut
Router(config-if)#exit
Router(config)#int Se0/1/1
Router(config-if)#ip address 4.0.0.2 255.0.0.0
Router(config-if)#no shut

Step 4 After ip address configuration we will configure each router in ip RIP routing like this

Router o

Router(config)#router rip
Router(config-router)#network 1.0.0.0
Router(config-router)#network 2.0.0.0

Router 1

Router(config)#router rip
Router(config-router)#network 2.0.0.0
Router(config-router)#network 3.0.0.0
Router(config-router)#network 4.0.0.0

Router 2

Router(config)#router rip
Router(config-router)#network 5.0.0.0
Router(config-router)#network 4.0.0.0

if you have problem in this rip routing so comment here i will solve your problem. you can also download rip routing lab through this link

thank you

by Vishnu  Sharma

Advertisements

how to configure FTP server in Redhat Linux Server part 1

hello guys today we will discuss how can we configure FTP(File Transfer protocol) Server in Redhat Linux Server .FTP server through we can download and upload any file or content.Its a very simple process if you follow my artical steps .so before we will install YUM server in our Linux machine because YUM is a very helpful service in package installation.if you want to know how to configure YUM in our linux machine so click on link and look   ftp serverso guys here i agree you configure YUM server in our ReadHat Linux Machine then we will contunue

step1= we will install Ftp package below commands 

[root@localhost ~]# yum install vsftpd* -y

Step2= then we will verify and start FTP service

[root@localhost ~]# service vsftpd restart
Shutting down vsftpd:                                      [  OK  ]
Starting vsftpd for vsftpd:                                [  OK  ]
[root@localhost ~]# service vsftpd status
vsftpd (pid 5668) is running...
[root@localhost ~]# chkconfig vsftpd on

Step3= Then we will off our machine firewall and selinux below commands 

[root@localhost ~]# iptables -F
[root@localhost ~]# setenforce 0

Ftp server is share /var/ftp directory if we have any data in  in this directory so client can download data through ftp server

Step4= then we will go Windows machine in and open any browser and put our linux IP Address

Ftp derver

then your Browser in open /var/ftp/ folder here you can download to here .we can also open FTP server in command prompt

if you have any problem in this process so comments here i will solve your problem

thank you

writer- Vishnu Sharma

How to configure Stelnet in redhat linux server

hello guys today we will discuss about secure telnet Server. basically secure telnet is a custom telnet its same copy of telnet server but here we will configure with our customize port.If you  want to know how to configure simple telnet server so click on link. before we telnet package in our linux machine. if we want we can install every type package easily  so  we need  to Yum server configuration you just click on link and look how to configure yum. Stelnet Server

Here I agree that you have configured YUM server in your machine

For any Tutorial visit linuxtiwary.com

Continue reading

How to configure NFS (Network File System )server in linux redhat

hello guys today we will configure NFS server in Linux redhat.if we configure  NFS Server in our Linux machine we can share easily  data each other easily. actually NFS server in share folder take real  space on server but all connected system in show visually. Linux server in NFS server is a very batter source of data sharing. so if you want to configure NFS server in your system so before configure YUM server in your system. yum Server is a very important in Linux we can install any package easily through YUM server. if you want to know how to configure yum server in our linux machine so click link and look

NFS server   here i agree you install yum server in your linux machine .then we start next Continue reading

How to Single Router working as Multiple DHCP Server Packet Tracer Lab

hello guys today we will discuss about DHCP router how can we provide ip address in different  network through router.actually we will make DHCP router and configure ip address through router.if you are interested in networking field or u prepare any networking exam so this tutorial is a very help full for  you. so let we startdhcp router

Step1 we will take three router and eight pc and create like this structure

Step 2 we will make router0 dhcp server. before we create connection each-other pc and router 

Step3 we will take serial wire and connect all router each-other 

Step 4 codeing for all routers 

ROUTER 0

Router>enable
Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#interface FastEthernet0/0
Router(config-if)#ip address 1.0.0.1 255.0.0.0
Router(config-if)#no shutdown
Router(config-if)#exit
Router(config)#interface Serial0/1/0
Router(config-if)#ip address 2.0.0.1 255.0.0.0
Router(config-if)#no shutdown

 

ROUTER 1

Router>enable
Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#interface FastEthernet0/0
Router(config-if)#ip address 3.0.0.1 255.0.0.0
Router(config-if)#no shutdown
Router(config-if)#exit
Router(config)#interface Serial0/0/0
Router(config-if)#ip address 2.0.0.2 255.0.0.0
Router(config-if)#no shutdown
Router(config-if)#exit
Router(config)#interface Serial0/0/1
ip address 4.0.0.1 255.0.0.0
Router(config-if)#no shutdown

 

ROUTER 2

Router>enable
Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#interface Serial0/0/0
Router(config-if)#ip address 4.0.0.2 255.0.0.0
Router(config-if)#no shutdown
Router(config-if)#exit
Router(config)#interface FastEthernet0/0
Router(config-if)#ip address 5.0.0.1 255.0.0.0
Router(config-if)#no shutdown
Router(config-if)#exit
Router(config)#interface FastEthernet0/1
Router(config-if)#ip address 6.0.0.1 255.0.0.0
Router(config-if)#no shutdown

 

Step 4 then we configure static routing for all router

STATIC ROUTING FOR ROUTER 0

Router(config)#ip route 4.0.0.0 255.0.0.0 2.0.0.2
Router(config)#ip route 5.0.0.0 255.0.0.0 2.0.0.2
Router(config)#ip route 6.0.0.0 255.0.0.0 2.0.0.2
Router(config)#ip route 3.0.0.0 255.0.0.0 2.0.0.2

STATIC ROUTING FOR ROUTER 1

Router(config)#ip route 1.0.0.0 255.0.0.0 2.0.0.1
Router(config)#ip route 5.0.0.0 255.0.0.0 4.0.0.2
Router(config)#ip route 6.0.0.0 255.0.0.0 4.0.0.2

STATIC ROUTING FOR ROUTER 2

Router(config)#ip route 2.0.0.0 255.0.0.0 4.0.0.1
Router(config)#ip route 3.0.0.0 255.0.0.0 4.0.0.1
Router(config)#ip route 1.0.0.0 255.0.0.0 4.0.0.1

Step 5 After static routing configuration we will go on router 0 and configure networl pool for all router 

Network pool one  for pc0 and pc1

Router(config-if)#ip dhcp pool one
Router(dhcp-config)#network 1.0.0.0 255.0.0.0
Router(dhcp-config)#default-router 1.0.0.1 

Network pool two   for pc 2 pc 3

Router(config)#interface Serial0/1/0
Router(config-if)#ip dhcp pool two
Router(dhcp-config)#network 3.0.0.0 255.0.0.0
Router(dhcp-config)#default-router 3.0.0.1

Network pool routerthree for pc 4  pc 5

Router(config-if)#ip dhcp pool routerthree
Router(dhcp-config)#network 5.0.0.0 255.0.0.0
Router(dhcp-config)#default-router 5.0.0.1

Network pool routerfour  for pc6 pc7

Router(config-if)#ip dhcp pool routerfour
Router(dhcp-config)#network 6.0.0.0 255.0.0.0
Router(dhcp-config)#default-router 6.0.0.1

Step6 now we wiil go in router1 and open FastEthernet0/0 port and put below commands

Router(config-if)#ip helper-address 2.0.0.1

now open pc2 and pc 3  ip configuration window and click on DHCP then you will get ip address dhcp routersame like we will go on router 2 command prompt and type below commands

network port  FastEthernet0/0         Router(config-if)#ip helper-address 2.0.0.1

network port  FastEthernet0/1         Router(config-if)#ip helper-address 2.0.0.1

if you have any problem in this process please comment here i will solve your problems.  you can also download  Single Router working as Multiple DHCP Server:Packet Tracer Lab through this link just one click and download

 

Thank you

by Vishnu Sharma

How to configure Apache Web Server in RedHat Linux

hello guys today we will learn how to configure Apache web Server  in Linux redhat and also host web page with Apache  web server. We will also understand concept of web server that how to host any website in Redhat Linux server. So before you need to  Configure YUM server in our  Linux machine. if you don’t know how to configure yum in linux so click on  link and look . After YUM server configuration we can install any package in Linux very easily

Step 1 here i accept you configure Yum in your Linux machine so fist we will install Http package

 

[root@localhost ~]# yum install http*

Step 2 then we off our Linux machine IP Address and also Disable Firewall and seLinux through below Commands 

[root@localhost ~]# ifconfig
eth0      Link encap:Ethernet  HWaddr 08:00:27:93:6D:E8
          inet addr:192.168.56.101  Bcast:192.168.56.255  Mask:255.255.255.0
          inet6 addr: fe80::a00:27ff:fe93:6de8/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:227 errors:0 dropped:0 overruns:0 frame:0
          TX packets:197 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:20134 (19.6 KiB)  TX bytes:25158 (24.5 KiB)

Here my ip address is 192.168.56.101

[root@localhost ~]# iptables -F
[root@localhost ~]# setenforce 0

Step 3 then we will Start httpd Service and go to any browser Url bar and put our Linux machine ip Address 

[root@localhost ~]# service httpd restart
Stopping httpd:                                            [  OK  ]
Starting httpd:                                            [  OK  ]

then we will look Apache web server description and instruction here    

Apache web server in linux Apache web server in linux

Step 2 now we will go our Linux terminal  and put below commands 

[root@localhost ~]# cd /var/www/html
[root@localhost html]#

Step3 here this directory in we will create simple Html page 

for example here i create index.html file

[root@localhost html]# vim index.html
<html>
<head> demo</head>
<title> Demo index File</title>
<body>
<h1> This is  Apache web Server Demo </h1>
<h2> you can found linux server all configureation in visworlditsolution.com</h2>
<marqoee><h2> visworlditsolution.com is a very help full website in it fields</h2></marqoee>\
</body>
</html>
~
~
~
:wq

Step4 then we will go  to Apache man configuration file and do something configure like this

[root@localhost html]# vim /etc/httpd/conf/httpd.conf
979 #
980 # VirtualHost example:
981 # Almost any Apache directive may go into a VirtualHost container.
982 # The first VirtualHost section is used for requests without a known
983 # server name.
984 #
985 #<VirtualHost *:80>
986 #    ServerAdmin webmaster@dummy-host.example.com
987 #    DocumentRoot /www/docs/dummy-host.example.com
988 #    ServerName dummy-host.example.com
989 #    ErrorLog logs/dummy-host.example.com-error_log
990 #    CustomLog logs/dummy-host.example.com-access_log common
991 #</VirtualHost>
992 <virtualHost 192.168.56.101:80>
993 DocumentRoot /var/www/html/
994 Directoryindex index.html
995 </VirtualHost>
:wq

Step5- we will restart httpd servies

[root@localhost html]# service httpd restart
Stopping httpd:                                            [  OK  ]
Starting httpd: [Thu Jan 19 05:05:47 2017] [error] (EAI 2)Name or service not known: Failed to resolve server name for 192.168.56.101 (check DNS) -- or specify an explicit ServerName
                                                           [  OK  ]
[root@localhost html]#

also check httpd below commands

[root@localhost html]# httpd -t

then we will on httpd  server below commands

chkconfig httpd on

 Step 6 now go to internet browser and type your linux machine ip address

web server Apache

Its a very simple process .if you have any problem in this process so please comments here i will solve your problem if you like my tutorial so follow my website like ,share,

Thank you

by Vishnu Sharma

 

How to broke/Split any file in redhat Linux Server

hello guys today we will learn how can we split any file in our linux machine its a very simple method .before we know why we split any file some time we need to send  any important data through E-mail but our data is very large. so we cant’t send through Email .so we can broke many parts in our data file and send. receiver will be collect all broke data file and make original data file. that plus point is we can split any extensions file like MP3, mp4, jpg .png.text .text PDF  everything .so let we will start just follow mefile split

Step 1 before we will create any file in 200MB size and then we will split in nine (9) parts 

[root@localhost ~]# dd if=/dev/sda of=demo.txt bs=2M count=100
100+0 records in
100+0 records out
209715200 bytes (210 MB) copied, 2.96287 seconds, 70.8 MB/s

now we have Demp.txt  file its size  is 210 mb .

Step2 now we will split in nine (9) parts through this commands 

( Note-Actually split commands is work on  bytes so  here we gave our split size 25000000kb )

[root@localhost expirment]# split -b 25000000 demo.txt
[root@localhost expirment]# ls
demo.txt  xaa  xab  xac  xad  xae  xaf  xag  xah  xai

Step3 now we will delete our demo.txt file

[root@localhost expirment]# rm -rf demo.txt
[root@localhost expirment]# ls
xaa  xab  xac  xad  xae  xaf  xag  xah  xai

here we dont’t have demo .txt file

Step4 now we can create original file through all broken parts   

[root@localhost expirment]# cat x*> demo.txt

when we will look our directory we found our demo txt file

[root@localhost expirment]# ls
demo.txt  xaa  xab  xac  xad  xae  xaf  xag  xah  xai

its a very useful and simple method if you have any problem in this method comments here i will solve your problem

Thank you

By Vishnu sharma